欢迎光临~bet必威体育
语言选择: 中文版 ∷  英文版

技术分享

路由模式实现局域网中三层交换机的互联

交换机有关vlan的配置:

 

switch#configure terminal !进入全局模式

 

switch(config)# vlan 10 !创建vlan 10

 

switch(config-vlan)# name test10 !改名为test10

 

switch#show vlan !显示vlan配置

 

 

 

switch(config-if)# interface fastethernet 0/5 !进入f0/5的接口配置模式

 

switch(config-if)#switchport trunk encapsulation dot1q

 

switch(config-if)#switchport mode trunk !修改端口模式为trunk

 

 

 

switch(config-if)# interface fastethernet 0/5 !进入f0/5的接口配置模式

 

switch(config-if)#switchport mode access !修改端口模式为trunk

 

switch(config-if)#switchport access vlan 10

实验拓扑:

 

实验步骤:

 

第一步:按照实验拓扑为各设备配名称、ip地址、子网掩码、网关等;并打开相应的端口。(以三层交换机A-A的配置为例,其他的设备参考A-A的配置进行相应的配置)。三层交换机的配置如下:

 

Switch>enable

 

Switch#conf

 

Switch(config)#hostname A-A

 

A-A(config)#ip routing

 

A-A(config)#int g0/1

 

A-A(config-if)#no sw

 

A-A(config-if)#ip address 172.16.1.1 255.255.255.0

 

A-A(config-if)#no shut

 

A-A(config-if)#int g0/2

 

A-A(config-if)#no sw

 

A-A(config-if)#ip address 192.168.1.1 255.255.255.0

 

A-A(config-if)#no shut

 

第二步:计算机A1、A2、B1相互ping对方会发现彼此不会ping通。此时在三层交换机上配置静态路由,以实验各主机之间通信。

 

在三层交换机A-A上的配置如下:

 

A-A(config)#ip route 192.168.2.0 255.255.255.0 172.16.1.2

 

在三层交换机B-B上的配置如下:

 

B-B(config)#ip route 192.168.1.0 255.255.255.0 172.16.1.1

 

第三步:测试计算机之间的连通性。

栏目导航

联系我们

CONTACT US

联系人:bet必威体育

手机:13932180720

电话:0311-80798059

邮箱:86424458@qq.com

QQ :86424458

地址: 石家庄桥西区裕华路海悦天地商务楼